Skip navigation
Welcome, Guest! Please Login or Join

Loading...

Magnavox Odyssey 2 Powers On, Weird Screen

May 10, 2010 at 12:25:18 PM
smeagolsama (211)
avatar
(Bronner's Army) < El Ripper >
Posts: 1412 - Joined: 01/28/2010
Missouri
Profile

I've taken my Odyssey 2 out of storage and am having trouble.  I know of videopac.org but I figured I might try here seeing as how helpful this community has been to me.

Plugs in, powers up, but I get a an offwhite grey screen.  I can try different carts usually with the same results.  I buttons on the oddysey it'll beep and boop and display different screens.  One screen I get a lot of is a pinkish screen with what looks like a bad equation.  Q+a = 1 or something like that.  I've taken it apart and cleaned it up some, and used a toothbrush with some alcohol where the carts plug into the mainboard.  I've cleaned the carts I've tried playing.

Any advice would be appreciated, as I would love to have this working.

Edit, If you have any questions or ideas let me know, I can also get screenshots.  I think one time I seen what I thought might have been a game pop up on a screen for a second or two.



Edited: 05/10/2010 at 12:26 PM by smeagolsama

May 21, 2010 at 9:38:37 AM
smeagolsama (211)
avatar
(Bronner's Army) < El Ripper >
Posts: 1412 - Joined: 01/28/2010
Missouri
Profile

Gonna move this to the front page. Hopefully someone can help.

Edit, this will be the last for this help wanted.  After this falls off the first page it's going back into storage.



Edited: 05/21/2010 at 09:39 AM by smeagolsama

May 22, 2010 at 5:56:18 PM
ars2pd (181)
avatar
(aRs !) < King Solomon >
Posts: 3625 - Joined: 11/04/2008
Missouri
Profile
These always seem to have problems, and are practically worthless I have found out. Sorry I cant help, but Hopefully you get it fixed!