Skip navigation
Welcome, Guest! Please Login or Join

Loading...

Strange problem with SNES Game Genie One of the code bits may be stuck?

Mar 13 at 10:07:15 PM
SUBSCRIBER
Kosmic StarDust (44)
avatar
(Ay Jay Will-Yams) < Master Higgins >
Posts: 9117 - Joined: 09/10/2011
Louisiana
Profile
I think my Game Genie has a stuck bit. I've haven't touched it in a couple years but I never had issues with it in the past. Last time I used it was on stock hardware, to grant infinite lives while playing the physical cart of Guntz's SML v3 Super Mario World hack, and enabling the feather cape to reach some hard to reach spots. Recently the Super NT gave me a renewed interest in everything Super Nintendo related, and I have run into so problems with the device itself.

Anyway I made a youtube video of the behavior.



EDIT: reupload video (previous video aborted last night during processing for some reason)

Basically the third character on the code input screen entry appears to have a stuck bit in it. Upon reset, some codes entered have the wrong character assigned, and they still don't work properly when entered. It exhibits the same behavior on stock hardware as well as the Super NT.

Is there potential to fix it, or should I just buy another one?  

-------------------------
~From the Nintendo/Atari addict formerly known as StarDust4Ever...


Edited: 03/14/2018 at 08:19 AM by Kosmic StarDust

Mar 14 at 8:23:20 AM
SUBSCRIBER
Kosmic StarDust (44)
avatar
(Ay Jay Will-Yams) < Master Higgins >
Posts: 9117 - Joined: 09/10/2011
Louisiana
Profile
Having issues with youtube aborting the video. Basically the 3rd character of the code appears to be wrong after entry for some reason.

-------------------------
~From the Nintendo/Atari addict formerly known as StarDust4Ever...